Yes, the site was down E-mail
User Rating: / 1
PoorBest 
Written by Norb Timpko   
Sunday, 11 July 2010 21:18

It was our webhosting company, JustHost, that had the issues.  We logged our complaints many times.  I now see slams about them showing up all over the web and they deserve it.  What happened, just should not happen in this day and age.  They assure me that they have fixed the issues and it "cannot" happen again.  We shall see...

 

JustHost hosts this site and they have very fast servers. We used to host this site on yahoo, but it was slow. Now we use JustHost and it's very fast.

Friday about 10am EST they took down the server that we run on. We do not have a dedicated box, but it's a shared server. Many people have been mentioning problems with the server lately, I guess it finally got to the no-go point. They ran a full file system check, then restored an old backup (about 4 days), then finally got it back online around 15+ hours later. I was very upset, sent lots of nasty emails, posted bad reviews around about it. They should have a backup server to run in these situations, obviously they do not.

So we lost lots of forum posts, also many bug reports as we host our bug database here as well. It really sucks! But it's one of those things that we'll just have to live with. We do not have a more recent backup ourselves so we just have to suck it up.

I apologize for anything lost, it hit the team hardest, but we're back up and hopefully in a better state than before.

Our activation server is NOT hosted here. That is run by another company and they DO have backup servers. This problem could never happen with our activations, so there is no need to worry about that. It effected any email accounts we had here, some mailing lists, and of course these forums.

We also do not host any of the purchase information on our servers, that too is all hosted by specialists in those fields. We just have the links to go to the places where a more solid system holds the information.

I hope that it has not caused anyone too many issues. It's all sorted out now. We had some issues a little later, but the response was that they were moving everyone to the new server and now it is done. So now it should work great. We hope so, switching hosting companies is a pain.
Last Updated on Wednesday, 03 November 2010 13:17
 

Discuss this article
You need to log in or register to participate in this discussion.