Statistics

Users
3537
Articles
156
Articles View Hits
1600522

Bug found?

11 years 1 month ago #31 by norb-1

  • Banned
  • Banned
  • There is a time for everything

  • Posts: 3716
  • Thank you received: 561

  • Gender: Male
  • Birthdate: 30 Nov 1968
  • Replied by norb-1 on topic Re:Bug found?
    rckgunny wrote:

    but as far as using minimal setting thats kind of redundant. all games on the markets should be able to run at max setting for you release them .


    Yeah, on the right machine. But there are a lot of games that I have that I can't run on max settings. Be nice if we lived in a perfect world like that, but that only exists in console gaming.

    The main point is that we put in a lot of options for people to find the set that work for them. It is impossible for us to debug every single PC configuration. If the CTD was in the code, it would CTD for us when we ran it as well. If it doesn't then it's something with your computer with your settings. When we get a saved game that will CTD for us, we fix it. If yours did, we would fix it. If it doesn't, then you have to work harder on your end to figure out why it's crashing for you. What combination of settings. That means you start with the lowest and work your way up.

    NSD Programmer/Producer
    "Leave these men alone! Let them go! For if their purpose or activity is of human origin, it will fail. But if it is from God, you will not be able to stop these men; you will only find yourselves fighting against God.” - Gamaliel 40 A.D.

    Please Log in or Create an account to join the conversation.

    11 years 1 month ago #32 by rckgunny

  • SOW Lt General
  • SOW Lt General

  • Posts: 162
  • Thank you received: 2

  • Gender: Male
  • Birthdate: 15 Jan 1956
  • Replied by rckgunny on topic Re:Bug found?
    also 1 more small detail! if your game files had any viruses when i downloade it. it would not have alloew me to download your program. webroot would have red tagged your game program and sent the red tag to microsoft and the world wide web pages IE and firefox, etc. webroot is the anti virus program app. all the major companys are using now. no its not cheap! i used to use AVG from trend micro . but this one is better, because this program will fix a computer even after its already got a trogin virus or any virus for that matter. even the government agencys are now using webroot anti viruses. theres nothing better atm .unless you have u.s. military anti virus program.
    [which is not allowed to the public] i checked.

    rckgunny

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #33 by JMayer

  • Junior Member
  • Junior Member

  • Posts: 67
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • Norb,

    I read in your patch updates it says that tc'ed commanders will obey orders. They are tc'ed and won't respond to courrier orders given by me the div. commander. Is there something to make them respond to tc'ed orders so they don't think for themselfs and move the brig when I tc them? I tc them so they stop thinking but I would like them to obey my commands when I tell them under TC.

    Thanks
    JMayer

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #34 by Little Powell

  • NSD Designer
  • NSD Designer

  • Posts: 4875
  • Thank you received: 1054

  • Gender: Male
  • Birthdate: Unknown
  • JMayer wrote:

    Norb,

    I read in your patch updates it says that tc'ed commanders will obey orders. They are tc'ed and won't respond to courrier orders given by me the div. commander. Is there something to make them respond to tc'ed orders so they don't think for themselfs and move the brig when I tc them? I tc them so they stop thinking but I would like them to obey my commands when I tell them under TC.

    Thanks
    JMayer


    I don't have access to the game now so I can't try this out, but this was fixed, tested, and the bug was closed. Maybe there's something else going on there.. Hopefully someone else can try it out to verify.. If not, I'll get to it later this evening.

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #35 by ADukes

  • SOW General
  • SOW General

  • Posts: 862
  • Thank you received: 91

  • Gender: Male
  • Birthdate: Unknown
  • Verified. Movement commands by mouse click for TC'ed units don't work.

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago - 10 years 9 months ago #36 by JMayer

  • Junior Member
  • Junior Member

  • Posts: 67
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • so movement as I do before they are tc'ed won't work? How do you get them to move then?I use courriers by brig only so this is very important for me to know. This is ment to be a bug report issue not complaint . Thanks again

    JMayer
    Last edit: 10 years 9 months ago by JMayer.

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #37 by ADukes

  • SOW General
  • SOW General

  • Posts: 862
  • Thank you received: 91

  • Gender: Male
  • Birthdate: Unknown
  • unTC -> Move -> TC

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago - 10 years 9 months ago #38 by Marching Thru Georgia

  • SOW General
  • SOW General
  • Secession Is Futile

  • Posts: 1737
  • Thank you received: 430

  • Gender: Male
  • Birthdate: Unknown
  • Replied by Marching Thru Georgia on topic Re:Bug found?
    JMayer wrote:

    so movement as I do before they are tc'ed won't work?

    Un-TC'd units will respond to courier orders. It seems that courier orders are not being delivered to TC'd units. For now, the solution is to un-TC the unit before the order is delivered. Once it has responded, TC it. It's a pain, but I don't think there is any other way at this time. But why TC a unit and order it around via courier? Why not just use the mouse to move it? TCing usually means that the player is unhappy with the AI's performance and the unit needs micromanagement. Courier orders do not allow that level of control.

    I can make this march and I will make Georgia howl.
    Last edit: 10 years 9 months ago by Marching Thru Georgia.

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #39 by PatCleburne

  • New Member
  • New Member

  • Posts: 12
  • Thank you received: 3

  • Gender: Male
  • Birthdate: 24 Aug 1997
  • Replied by PatCleburne on topic Re:Bug found?
    Dude. Calm down just a little bit. No need to be so rude when you are asking for help. Do you think Sid Meier answered questions for his games when they were buggy?

    "Where this division defended, no odds broke its line; where it attacked, no numbers resisted its onslaught, save only once; and there is the grave of Cleburne." - William Joseph Hardee, Lieutenant General CSA.

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #40 by JMayer

  • Junior Member
  • Junior Member

  • Posts: 67
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • Replied by JMayer on topic Re:Bug found?
    I know that for now you must un TC the commander I am just bringing to the attention of NorbSoftDev that this bug needs to be looked at for all to enjoy the full game with courriers. I for one am very calm and will wait for it to be fixed.
    If they don't know of the bug they won't beable to fix it.
    THanks,
    JMayer

    Please Log in or Create an account to join the conversation.

    10 years 9 months ago #41 by Little Powell

  • NSD Designer
  • NSD Designer

  • Posts: 4875
  • Thank you received: 1054

  • Gender: Male
  • Birthdate: Unknown
  • Replied by Little Powell on topic Re:Bug found?
    JMayer wrote:

    I know that for now you must un TC the commander I am just bringing to the attention of NorbSoftDev that this bug needs to be looked at for all to enjoy the full game with courriers. I for one am very calm and will wait for it to be fixed.
    If they don't know of the bug they won't beable to fix it.
    THanks,
    JMayer


    And thanks for bringing it up. It was supposed to be fixed, not sure how we overlooked this one. The report has been re-opened and we are looking into it.

    Please Log in or Create an account to join the conversation.

    10 years 8 months ago #42 by Joshua l.Chamberlain

  • Regimental Commander
  • Regimental Commander
  • Go where the fire is the hottest!

  • Posts: 327
  • Thank you received: 1

  • Gender: Male
  • Birthdate: 30 Nov 1984
  • Replied by Joshua l.Chamberlain on topic Re:Bug found?
    I have found a bug where when the infantry charge their guns go solid black instead of retaining their colors.

    "There stands Jackson like a stone wall! Let us be determined to die here and we will conquer!"
    -Brig.Gen. Bernard Bee, Henry House

    Please Log in or Create an account to join the conversation.

    10 years 8 months ago #43 by Little Powell

  • NSD Designer
  • NSD Designer

  • Posts: 4875
  • Thank you received: 1054

  • Gender: Male
  • Birthdate: Unknown
  • Replied by Little Powell on topic Re:Bug found?
    Joshua l.Chamberlain wrote:

    I have found a bug where when the infantry charge their guns go solid black instead of retaining their colors.


    Can you grab a save of this? I've never seen this happen, but you can catch a save of it, we'll look into it.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #44 by Son of an Irish Noble

  • Junior Member
  • Junior Member

  • Posts: 40
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • Replied by Son of an Irish Noble on topic Re:Bug found?
    This may not technically be a bug, but attack and defense sandbox battles still won't load full armies (if you chose army, it will load the army commander and one corps chosen at random.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #45 by Little Powell

  • NSD Designer
  • NSD Designer

  • Posts: 4875
  • Thank you received: 1054

  • Gender: Male
  • Birthdate: Unknown
  • Replied by Little Powell on topic Re:Bug found?

    This may not technically be a bug, but attack and defense sandbox battles still won't load full armies (if you chose army, it will load the army commander and one corps chosen at random.


    It will load a full army but it may take a couple tries to get it. I just chose an attack sandbox game, day 3, and I had control of Lee's whole army, all three corps.

    The system is setup to randomly balance the forces so again sometimes it may take a few tries to get a balanced game that has multiple corps.

    There's a request in to have the option to keep the numbers historical or balance them.

    Keep in mind though, a full army battle will take up A LOT of CPU speed and is not recommended. There's another request in to have the Sandbox.ini moddable so that the sprite ratio can be reduced to allow the huge battles.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #46 by Son of an Irish Noble

  • Junior Member
  • Junior Member

  • Posts: 40
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • Replied by Son of an Irish Noble on topic Re:Bug found?
    It seems like a kind of odd way to set it up. If I wanted a balanced battle, I could pretty easily edit the order of battle (and if I could do that, you know it's not too tough). If I wanted to fight with a corps, I would select corps v corps. Sometimes I want to defend against overwhelming odds (or attack with them).

    I could see giving the option of autobalancing, but doing so by default for only those engagement types just strikes me as strange.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago - 10 years 7 months ago #47 by Son of an Irish Noble

  • Junior Member
  • Junior Member

  • Posts: 40
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • Replied by Son of an Irish Noble on topic Re:Bug found?
    Sorry to doublepost, but if you wanted a real bug for some reason buildings don't load anymore with the new patch. This could be something dumb I'm doing, but I couldn't find any graphic options.

    Edit: Also, use roads command doesn't work when issued by courier
    Last edit: 10 years 7 months ago by Son of an Irish Noble.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #48 by Marching Thru Georgia

  • SOW General
  • SOW General
  • Secession Is Futile

  • Posts: 1737
  • Thank you received: 430

  • Gender: Male
  • Birthdate: Unknown
  • SOAIN wrote:

    Sorry to doublepost, but if you wanted a real bug for some reason buildings don't load anymore with the new patch. This could be something dumb I'm doing, but I couldn't find any graphic options.
    Edit: Also, use roads command doesn't work when issued by courier

    Buildings display just fine for me. Check and see if you have turned down 'Show Map Objects' on the 2nd page of Options.

    The stock courier order 'Use Roads' only works for units of brigade size or larger. If you want to use this command for regiments, you can download my latest Couriers & Maps mod which has appropriate 'Use Roads' commands for both.

    I can make this march and I will make Georgia howl.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #49 by Son of an Irish Noble

  • Junior Member
  • Junior Member

  • Posts: 40
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • I was more concerned with use roads for division and up

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #50 by Son of an Irish Noble

  • Junior Member
  • Junior Member

  • Posts: 40
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • SOAIN wrote:

    Sorry to doublepost, but if you wanted a real bug for some reason buildings don't load anymore with the new patch. This could be something dumb I'm doing, but I couldn't find any graphic options.
    Edit: Also, use roads command doesn't work when issued by courier

    Buildings display just fine for me. Check and see if you have turned down 'Show Map Objects' on the 2nd page of Options.

    The stock courier order 'Use Roads' only works for units of brigade size or larger. If you want to use this command for regiments, you can download my latest Couriers & Maps mod which has appropriate 'Use Roads' commands for both.


    Show map objects on high. I get all the white picket fences and stone walls but no houses and no rivers. I'm running an NVidia 9200 GS in a notebook. I remember laptops had issues with displaying map objects in Bull Run 1, is that still the case?

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #51 by Marching Thru Georgia

  • SOW General
  • SOW General
  • Secession Is Futile

  • Posts: 1737
  • Thank you received: 430

  • Gender: Male
  • Birthdate: Unknown
  • SOAIN wrote:

    Show map objects on high. I get all the white picket fences and stone walls but no houses and no rivers.

    That's the problem. The 'Show Map Objects' has to be on 'Best' to show the buildings. If that slows your computer down too much, lower the 'Percent Trees Showing' to 70% or so. That should speed things back up.

    I can make this march and I will make Georgia howl.

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #52 by Son of an Irish Noble

  • Junior Member
  • Junior Member

  • Posts: 40
  • Thank you received: 1

  • Gender: Unknown
  • Birthdate: Unknown
  • Ah, I thought high was the highest setting :blush: . Thanks for the assistance

    Please Log in or Create an account to join the conversation.

    10 years 7 months ago #53 by Marching Thru Georgia

  • SOW General
  • SOW General
  • Secession Is Futile

  • Posts: 1737
  • Thank you received: 430

  • Gender: Male
  • Birthdate: Unknown
  • SOAIN wrote:

    Also, use roads command doesn't work when issued by courier

    You're right!! There has been a change in the 'useroad' command in the latest version. I have reported it. Until it is fixed, you can use the latest Courier&Maps mod which has the proper command in it. Of course that won't help MP. :(

    I can make this march and I will make Georgia howl.

    Please Log in or Create an account to join the conversation.

    5 years 10 months ago #54 by millerpsc

  • New Member
  • New Member

  • Posts: 2
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Replied by millerpsc on topic Re: Bug found?
    when I am playing army vs army in sandbox about 80% of the units wont fire, I've done several reinstalls but it always happens. During the first few minutes of fighting there is no issue but it seems that once a large number of units begin to be engaged the bug (if that's what it is) kicks in. The only way to fight the remainder of the battle is to go into melee but the enemy usually wont fight back during melee. Any ideas on what this could be and how to resolve it?

    Please Log in or Create an account to join the conversation.

    5 years 10 months ago #55 by Chamberlain

  • NSD QA Team
  • NSD QA Team

  • Posts: 1157
  • Thank you received: 212

  • Gender: Male
  • Birthdate: 10 Jul 1955
  • Replied by Chamberlain on topic Re: Bug found?
    millerpsc,

    It has to do with large size OOB's, a computers specs and the AI's Cycle. See below links :

    www.norbsoftdev.net/forum/technical-help-a-bug-post/51959-units-not-firingdoing-damage#51959

    www.norbsoftdev.net/forum/technical-help-a-bug-post/60970-units-stop-firing#60970

    Chamberlain

    -Col. Joshua Chamberlain, 20th Maine

    We cannot retreat. We cannot withdraw. We are going to have to be stubborn today
    The following user(s) said Thank You: millerpsc

    Please Log in or Create an account to join the conversation.

    5 years 10 months ago #56 by millerpsc

  • New Member
  • New Member

  • Posts: 2
  • Thank you received:

  • Gender: Unknown
  • Birthdate: Unknown
  • Replied by millerpsc on topic Re: Bug found?
    ok thanks for the quick reply, I'll try to lower settings and sprite ratios

    Please Log in or Create an account to join the conversation.

    Moderators: ShirkonChamberlainFlanyboy